[ gpsdrive ] Installation / running gpsdrive packave (v 2.10svn16984604) on Debian Etch

Florian Schmitt ml-gpsdrive at florian-schmitt.net
Sat Sep 22 02:32:57 AKDT 2007


Hi,

i've got some problems trying to install GPSDrive 2.10svn16984604 on
Debian Etch. I simply added the gpsdrive repository to the sources,
imported the PGP Key, refreshed the package list and tried to install
the gpsdrive package using aptitude.

First problem was a missing dependency - post-installation of gpsdrive
(creation of the mysql tables) failed because slurp was missing. After
installing the package libfile-slurp-perl, the installation succeded.

But when i try to run gpsdrive, i get:

florian at migdal:/opt$ gpsdrive
gpsdrive: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found
(required by gpsdrive)

The following libstdc++ packages are installed:

florian at migdal:/opt$ dpkg -l | grep libstdc++
ii  libstdc++2.10-dev                     2.95.4-27
      The GNU stdc++ library (development files)
ii  libstdc++2.10-glibc2.2                2.95.4-27
      The GNU stdc++ library
ii  libstdc++5                            3.3.6-15
      The GNU Standard C++ Library v3
ii  libstdc++6                            4.1.1-21
      The GNU Standard C++ Library v3
ii  libstdc++6-4.1-dev                    4.1.1-21
      The GNU Standard C++ Library v3 (development files)
ii  libstdc++6-dev                        3.4.6-5
      The GNU Standard C++ Library v3 (development files)

What i'm doing wrong? Thanks in adavance!

florian


More information about the GPSdrive mailing list