[ gpsdrive ] Cannot add a waypoint to $HOME/.gpsdrive/way.txt

Thomas Schönhütl pilleus.pulcher at arcor.de
Sun Sep 23 23:37:16 AKDT 2007


Hi,
>> /usr/src/gpsdrive-2.10svn16984604/src/map_handler.c:664: undefined
>> reference to `get_mapnik_imagedata'
>>
>>     
> AFAIK you need mapnik to compile. if you don"t use mapnik, you could try 
> a ./configure --disable-mapnik
>   
I tried this option quite in the beginning, but no success! 
--disable-mapnik is working in version 2.10svn15113909 without any problems.
>   
>> And the version out of SVN-Repository (I thought this one is the latest!?!)
>>
>> slack at medino: ~ $ gpsdrive -D 1
>>
>> gpsdrive (c) 2001-2006 Fritz Ganter <ganter at ganter.at>
>>
>> Version 2.10svn15113909
>> $Id: gpsdrive.c 1477 2007-07-09 21:50:01Z dse $
>>
>>     
> yes, if you do a fresh checkout, it is the latest. but your version is about 
> two month old :-)
>
> this is my current version:
> Version 2.10svn16684589
> $Id: gpsdrive.c 1695 2007-09-16 10:00:03Z loom $
>   
May be I do something wrong, but the given command on gpsdrive's 
homepage is this:

| svn co http://svn.gpsdrive.cc/gpsdrive/trunk gpsdrive-svn

And with this command I get the posted version |2.10svn15113909. I tried 
it several times, this is the latest version I get (three days ago and 
just at the moment). I deleted the svn directory and downloaded it 
again, I tried a "svn update", no go.

Thomas Schönhütl.



More information about the GPSdrive mailing list