[ gpsdrive ] [Gpsd-users] Success! Garmin USB18 T.S. Suse-10.3

gpsdosm at trixtar.org gpsdosm at trixtar.org
Mon May 26 12:25:08 AKDT 2008


Great Gary wrote:
> 
> Yo gpsdos!
> 
> On Sat, 24 May 2008, gpsdosm at trixtar.org wrote:
> 
>>> gpsd uses /proc/bus/usb/devices to verify if the kernel driver is
>>> installed.  Some distros have stopped providing /proc/bus/usb and
>>> that is causing problems for gpsd detecting if the garmin kernel
>>> driver is installed.

>> /proc/bus/usb is empty  BTW
> 
> Then that is the show stopper right there.  If you can mount /proc/bus/usb
> then you should be fine.  Long term we must find another way to determine
> if the garmin_gps driver is loaded.

Thanks for the help, looks like the unit is working and that's the 
major load off my mind. The laptop don't connect to the net on account 
of no drivers for the SMC-N wifi buscard, the desktop can't read sats 
indoors, so it's been a lot of shuffling in and out but ..at long last 
I got data out of it!

I hope you don't mind my replying (depersonalized) to the list and 
copying to the gsdrive list (and alt.os.linux.suse later) in case some 
poor soul is googling for this workaround. I've been at it for two 
weeks now on and off, including XP related resources that still hadn't 
netted any results. Your lead did 10 minutes ago.


# mount /proc/bus/usb

I don't understand this proc business and it's over my head but it 
worked, don't know what other method could have worked under suse, 
obviously intervention was required that shouldn't be required. When I 
installed gpsd and the little clients all dependancies were satisfied. 
Whatever.


# killall gpsd
# killall gpsd
gpsd: no process killed


# gpsd -N -D 6 /dev/ttyUSB0
   lotsa stuff coming down..

# killall gpsd
# killall gpsd
gpsd: no process killed

# gpsd /dev/ttyUSB0

# gpspipe -r
   lotsa stuff

# gpsdrive
Can't connect to local MySQL server through socket 
'/var/lib/mysql/mysql.sock' (2)
Creating main window
way.txt: No such file or directory
Read 503 POI-Types from /usr/share/map-icons/icons.xml
map_koord.txt reloaded
way.txt: No such file or directory
way.txt: No such file or directory
way.txt: No such file or directory

BUT..
gps time = good, status = 3d fix  Pos=bang on.

Now I can get on with learning to decode raw data for myself and 
recording some tracks for OSM :-)

Bless You.








More information about the GPSdrive mailing list