[ gpsdrive ] 2.10pre8 branching [was: Screen size]

Guenther Meyer d.s.e at sordidmusic.com
Wed May 19 00:38:21 AKDT 2010


On Wed, May 19, 2010 at 12:10:39AM -0700, Hamish wrote:
> schrieb Hamish:
> > > any objections to me branching off r2527 as 2.10pre8, then backporting
> > > the ability to use the new gpsd API to that branch?
> 
> Guenther wrote:
> > AFAIR ist 2.11 a branch of r2527.
> 
> yes, that is correct. excellent!
> 
> do you know if there any were more commits than the initial r2728 and
> r2729 needed to (optionally) support gpsd 2.92+ ? 
>
r27xx?
I know you are some hours ahead at your side of the marble, but that counts also for the repository...?
;-)

r2528 and r2529 should be all there is.


> > packages built from trunk should usually have a naming like 2.11svn2551.
> 
> hmmm, shouldn't packages built from the 2.11 branch be named like that,
> and packages built from trunk be named like 2.12svn2551 ?
>
hmm, svn-packages should always be from trunk, not from a branch, IMO.
as the svn-packages are usually snapshots of a moving target, they should have an odd version number, marking the "more or less unstable" development status.
otherwise it would be a bugfix release (or preliminary packages for one); unless someone decides to develop new features for a released branch).



More information about the GPSdrive mailing list