[ gpsdrive ] Where is gpsdrive_2.10pre7_i386.deb ?

Paul Martin pm at debian.org
Wed May 26 01:19:44 AKDT 2010


On Wed, May 26, 2010 at 09:06:48AM +0200, Joerg Ostertag wrote:

> These are all the gpsdrive 2.11 files on the webserver ...

> http://www.gpsdrive.de/debian/pool/squeeze/gpsdrive-data-maps_2.11_all.deb
> http://www.gpsdrive.de/debian/pool/squeeze/gpsdrive-friendsd_2.11_amd64.deb
> http://www.gpsdrive.de/debian/pool/squeeze/gpsdrive-friendsd_2.11_i386.deb
> http://www.gpsdrive.de/debian/pool/squeeze/gpsdrive-utils_2.11_amd64.deb
> http://www.gpsdrive.de/debian/pool/squeeze/gpsdrive-utils_2.11_i386.deb
> http://www.gpsdrive.de/debian/pool/squeeze/gpsdrive_2.11_amd64.deb
> http://www.gpsdrive.de/debian/pool/squeeze/gpsdrive_2.11_i386.deb

It looks like you've forgotten to update the Packages files, so
"apt-get update" doesn't see them.

There are other problems...

Depends: ... libmapnik0.6, ... libmapnik (>> 0.5.0-1) | libmapnik0.5, ...

The current version of Mapnik in squeeze is libmapnik0.7, with no 0.6
version. Lenny doesn't contain libmapnik0.6, so it's not installable
there either.

Depends: ... libgps18 (>= 2.39), ...

Squeeze contains only libgps19, and lenny only libgps17, so it's not
installable on either.

Recommends: ... gpsdrive-data-maps (>> 2322), ...

Now, that's odd. Where am I going to get that version? You're
providing 2.11.

Recommends: ... postgresql-8.3-postgis | postgresql-8.2-postgis, ...

Squeeze contains only postgresql-8.4-postgis, and not the two given there.

Now looking at gpsdrive-data-maps_2.11_all.deb...

Conflicts: gpsdrive (<< 2322)

Can you see the problem there? You're providing gpsdrive version 2.11
which is a much smaller number than 2322. The two won't install
together.


-- 
Paul Martin <pm at debian.org>


More information about the GPSdrive mailing list